Get Professional Help For Your Vehicle

13919 Questions
Updated: September 30 2014
    Login   Sign Up

Paid Up And Waiting For Help

--- Sorry, All Questions Are Engaged ---

Questions Need Answers
1999 Engine Chev 1999
1999 Chevy Tahoe with 5.7. Engine starts and then immediately shuts off. Will remain running on ether, but shuts off when you stop spraying. Changed the fuel filter and entire sending unit, to no avail. Any suggestions?

September 30 14:15 by hammer2288 This question hasn't been paid for. You can make an offer

Make an offer
2006 Chevrolet 2006 Chevy Express
my van will quit and run out of gas when the gas is only just under a 1/4 what is the problem?

September 30 08:00 by nitag717 This question hasn't been paid for. You can make an offer

Make an offer
1997 Nissan Sentra
My 1997 Sentra will stop running after it runs 10-20 miles. If I wait until the engine cools off it will start right up and go another 10-20 miles. I have replaced the crank sensor, Fuel pump, fuel filter, plugs, plug wires, distributor cap and both o2 sensors. My car just turned 250k so as you can see I pretty much did an entire tune-up. Oh there were no codes that showed up to give me any clue.

September 28 18:17 by Eric_S This question hasn't been paid for. You can make an offer

Make an offer
2000 Ford Taurus
2000 Ford Taurus - When I Start Car It Starts But Makes A Clicking Noise Around Engine Some Smoke Comes Out Not Sure From Where But Coming From Under Hood.if I Step On Gas Or Brake The Noise Is Louder Also Some Shaking

September 28 13:17 by mrs.sarabia This question hasn't been paid for. You can make an offer

Make an offer
1993 Ford 1993 Explorer 4.0 V6 4x4 Xlt
My 1993 Ford explorer 4.0v6 4x4 xlt. Dosn't want to shift to high gear and the Rpm run high what's wrong

September 27 12:31 by andrew_frye This question hasn't been paid for. You can make an offer

Make an offer
2005 Mazda B2600f
my2005 mazda b2600f with the g6 engine has trouble starting after sitting for a couple of weeks. I have to keep winding it over and pumping the gas pedal. If it has been sitting out in the sun on a hot day it will eventually start but if but if it is cold there is no chance and I have to use a starting aid (aerostart spray). It also runs rough at idle like its missing a little cause I can feel it shake the car slightly like its just not running smooth and when I put my foot down to hard it wont rev up smoothly I kind of chokes a bit. I suspect an air leak in the fuel system as if the fuel is leaking back to tank and just wanted to know where it is most likely to be losing fuel pressure e.g where the fuel lines usually leak or which seal in the pump usually causes problems. It also uses more fuel than it should be and is costing me more to run than a relatively late model four cylinder engine should. any help would be most appreciated and will save me a lot of time and money. Regards Frankiefnb

September 27 00:10 by frankiefnb This question hasn't been paid for. You can make an offer

Make an offer
1991 Ford Mustang
Hi there, big problem with my 91 lx 4cyl. Mustang! When I Turn On My Car I Have Instant Power Loss, My Batter Gauge Is Super Low And My Temp Gauge Goes Crazy Saying It's Super Hot But Clearly It's Not. The Fun Begins When I Try To Go Anywhere It Starts To Buck Super Bad And My RPMs Go Up And Down With The Bucking, My Radio And Electrical System All Blink On And Off With The Bucking, As I Go Through My Gears The Bucking Gets Better. When It First Started I Just Unplugged My Negative Battery Terminal And It Would Run Fine But Now It's Permanent Now. I Have No Idea What The Problem Is And Neither Does My Dad Or His Buddies Who Work On Cars! Please Help!

September 26 22:15 by 60fistpump This question hasn't been paid for. You can make an offer

Make an offer
1986 Ford Bronco
1986 bronco 5.0...the engine is fuel flooded immediately upon start or restart. The only way to get it started is holding the pedal to floor and it may run but is puffing heave black smoke from both ex pipes(dual exhaust) and once cleared up it runs great.

September 25 07:20 by dav This question hasn't been paid for. You can make an offer

Make an offer
1987 Engine Chev Astro Van
reverse slips on automatic transmission __ is there any adjustments to be made?

September 24 18:21 by Tu_Madre This question hasn't been paid for. You can make an offer

Make an offer
1992 Engine Nissan Stanza
1992 Engine Nissan Stanza - When My 92 Nissan Stanza's Ac Is Turn On It Starts To Idle Rough But Runs Ok When Ac Is Not On

September 24 07:31 by Bauer's_92 This question hasn't been paid for. You can make an offer

Make an offer
1993 Chevrolet Cavalier
93 cavalier turns off while running

September 23 09:04 by rothkelly6 This question hasn't been paid for. You can make an offer

Make an offer
1995 Toyota 1995
After driving for a while and turn engine off it won't restart until car sits for a while.It cranks but car won't start.

September 22 09:47 by bruceless This question hasn't been paid for. You can make an offer

Make an offer
1982 Honda Prelude
what needs to be done to start car after running out of gas

September 21 20:10 by clark_cain This question hasn't been paid for. You can make an offer

Make an offer
1989 Ford 89 Crown Victoria Wagon
the car almost starts for the fist 2-3 seconds and then seems to stop fireing

September 21 13:22 by FARONOAH This question hasn't been paid for. You can make an offer

Make an offer
1985 Ford Mustang 5.0
1985 Ford Mustang 5.0 - I Have A 1985 Ford Mustang 5.0 That Shuts Off When I Make A Left Turn. Any Ideas On A Solution?

September 21 01:25 by trnowlin This question hasn't been paid for. You can make an offer

Make an offer
1991 Honda 1991 Dx
My 91 civic DX runs great until it gets to 1/2 tank of fuel. When I reach 1/2 tank, it sputters and just stops. If I put another 6 gallons of fuel it will start right up and run great until the next time I reach 1/2 tank.

September 20 17:39 by Dougr This question hasn't been paid for. You can make an offer

Make an offer
1987 Chev Cavalier Caviler Z24
ok .it started with replaceing fuel pump computer ecm, injectors,plugs, fuel filter,tps,crank sensor,map sensor after all that it started and ran a few min and now wont start if I give it ashot of starting fluid it runs for a second

September 20 11:03 by monty123 This question hasn't been paid for. You can make an offer

Make an offer
1990 Honda Lx
is it possible to convert my whole inside interior of my 1990 honda accord with interior from a 1993 honda accord

September 20 07:04 by 3Tz This question hasn't been paid for. You can make an offer

Make an offer
1987 Chevrolet Cavalier
Needs starting fluid to start then dies when i give it gas

September 19 06:50 by Zeke_1977 This question hasn't been paid for. You can make an offer

Make an offer
1998 Ford Escort
I was driving my ford escort to work this morning my b4 I got there my headlights cut off

September 19 04:05 by Barry_B This question hasn't been paid for. You can make an offer

Make an offer
2004 Engine Ford Escape Xlt
My engine pulls very bad when I turn on my ac or defrost

September 18 12:28 by liv3love3laugh1121 This question hasn't been paid for. You can make an offer

Make an offer
1989 Nissan Maxima
sometimes when I turn the ignition key forward and be P light on the transmission mode does not come on when selected, the car will stay in 3rd gear only, but when I turn the key off and on again sometimes the light will come on and the car shifts perfectly normal. meanwhile the C light will come on when selected no matter what. Also, sometimes both lights will come on no matter where the mode selector switch is pressed and at that point the car will only stay in first gear. Help!!

September 17 14:12 by cat5canesfan This question hasn't been paid for. You can make an offer

Make an offer
1992 Ford Explorer
1992 Ford Explorer - My 92 Ford Explorer Wont Go Pass 40 Mph,i Replaced The Cat Converters Already But Still Doing The Same Thing?

September 17 03:47 by gcorona939_ This question hasn't been paid for. You can make an offer

Make an offer
1992 Ford Explorer
My 92 ford explorer wont go pass 40 mph,i replaced the cat converters already but still doing the same thing?

September 17 03:46 by gcorona939_ This question hasn't been paid for. You can make an offer

Make an offer
1990 Ford Taurus
Replaced fuel pump, filter, pressure regulator, plugs, wires, cap, rotor. when trying to start have to feather the gas to run and back fires through the air cleaner. the fuel pump twice now hasn't come on then I come back later and it works. The car sat for 5 years. I am lost from the computer less cars. Thank you

September 16 16:14 by elwooddually This question hasn't been paid for. You can make an offer

Make an offer
GL Ford Taures
When im driving my brights sig stays on even if i dont have the lights on, pluse i have to unhook the battery to get my headlamps and brights sig to go off. Its a 97 ford taurus.

September 16 11:52 by Vonpeep This question hasn't been paid for. You can make an offer

Make an offer
1994 AMC 1994mustang Gt 5.0
1994 AMC 1994mustang Gt 5.0 - Does My 94gt 5.0 Have A Crank Position Sensor?

September 15 13:32 by angela_floyd This question hasn't been paid for. You can make an offer

Make an offer
1989 Ford Mustang
Ok I have a 1989 ford mustang my step dad got for me he did a bunch of work on it and fixed a lot of stuff but one thing we can't figure out when I drive it I have to keep pumping the gas petal for it to get speed he has put new censeror in everything that has to do with the fuel all new plugs and he just order a distributaries for it.. It just got it to idle right he has tried everything can somebody please help thanks

September 14 08:03 by Katie1991 This question hasn't been paid for. You can make an offer

Make an offer
1987 Ford Thunderbird
I need a vacuum hose routing diagram for a 1987 ford t-bird 5.0 LX with throttle-body stock.l

September 13 19:56 by strousebigmike@comcast.net This question hasn't been paid for. You can make an offer

Make an offer
1987 Ford T-bird
1987 Ford T-bird - Why Does The Window Console Buttons Only Work When The Ignition Switch Is Engaged But The Engine Is Not Started?

September 12 03:41 by artie This question hasn't been paid for. You can make an offer

Make an offer
1999 Ford Taurus
1999 Ford Taurus - I Have A '99 Taurus The Alternator Light Started Going On When I Would Drop Into Passing Gear, I Noticed Some Buildup On My + Battery Terminal Cleaned It Off And Cleaned The Post. Seemed To Be Ok For About 3 Miles, Then It Started Coming On Again. Was Just About To My Hotel And I Started Getting A Beep And The Air Bag Light Came On. I Know The Battery Is Old As It Is Not A Maintance Free One Could I Just Need A New Battery. Also Sometimes In Wet Weather The Door Ajar Light Will Stay On And The Dome Light Doesnt Go Out. The Door Ajar Light Problem Has Been On Going Since I Bought The Car 3 Years Ago.

September 11 18:12 by thefotochef This question hasn't been paid for. You can make an offer

Make an offer
1988 Nissan D21 Pickup
I have a 1988 d21 nissan pickup 2.4l z24 motor Manuel transmission 4 speed it starts and idles a little high but smooth the problem is when it gets to moving I don't have much gas peddle about idle is a much as I can get so 4th gear it tops out at about 45 until you reach a incline then it really bogs out I I give it more throttle it spits and sputters if I give it full it quits all together the motor is still running just doesn't rev I've replaced fuel pump, fuel filter, cap and rotor all 8 spark plugs and wires checked both coils they both shocked me I also did a compression test the other day everything was ok please help I can't keep throwing parts at it

September 11 13:44 by Nic-- This question hasn't been paid for. You can make an offer

Make an offer
98 Ford Explorer
I have a manual 98 ford explorer. When I turn the key I get nothing. But when I push start my truck it starts. What can be the problem? I don't have a check engine light that comes on.

September 11 09:37 by Iceman8313 This question hasn't been paid for. You can make an offer

Make an offer
1999 Engine Pontiac 2.4
i have a 1999 pontiac that went i was driving it began to slow down and then cut off won't move. it start then it cut back off.

September 11 09:26 by jonewilli This question hasn't been paid for. You can make an offer

Make an offer
1994 Ford 1994 Thunderbird V8
screeching noise when turning

September 11 05:40 by meconway This question hasn't been paid for. You can make an offer

Make an offer
1997 Engine Nissan Altima
I changed the alternator 1997 altima now its overheating it didn't overheat before no leaks anywhere

September 10 18:07 by juanie76 This question hasn't been paid for. You can make an offer

Make an offer
1998 Ford Explorer
my ford 5.0 litre V8 spits and sputters accelerating up to highway speed

September 10 17:47 by sasha_jo This question hasn't been paid for. You can make an offer

Make an offer
1987 Engine Nissan 300zx Turbo
1987 Engine Nissan 300zx Turbo - My1987 Nissan 300zx Turbo Will Start Up And Idle Fine Until I Push The Accelerater Down Then It Will Bog Out And When I Let Off The Accelerater It Goes Back To Idling Fine Can You Please Give Me Some Ideas To What The Problem Might Be

September 10 08:48 by kaleb This question hasn't been paid for. You can make an offer

Make an offer
1987 Engine Nissan 300zx Turbo
my1987 Nissan 300zx turbo will start up and idle fine until I push the accelerater down then it will bog out and when I let off the accelerater it goes back to idling fine can you please give me some ideas to what the problem might be

September 10 08:46 by kaleb This question hasn't been paid for. You can make an offer

Make an offer
1987 Ford E-350
doing the water pump two top bolts broke off ,in the head to extract them ,I had to remove the timing chain cover harmonic balance r assembly removed all the broken bolts put everything back together now it starts but will not fire ,I just put a new coil on still nothing also I used starting fluid but nothing,could I have messed up the assembly on the crank shaft in any way,I did hit it with a hammer a few times until I found out that was a no no also the starter relay got so hot it melted the ground wire I did volt meter check on that and believe I fixed the back wards wiring problem also I used starting fluid too no luck please help me before it get;s towed off

September 08 21:29 by lowemichael This question hasn't been paid for. You can make an offer

Make an offer
1997 Engine Chev 1997 Tahoe Chevrolet
i have a 1997 tahoe chevrolet. everytime i gets in the car and go about a mile, the care stops on me with no warning, can you help me

September 08 15:37 by mary.m.clark@comcast.net This question hasn't been paid for. You can make an offer

Make an offer
2002 Engine Nissan 3.5
Idles funny dies randomly misses slightly exhaust loud

September 08 09:22 by jentabor This question hasn't been paid for. You can make an offer

Make an offer
1992 Honda 1992
Hi.. I'm nick. My 92 honda prelude has been giving me a lot of problems.. sometimes it won't start. As I try to start it., back fires and blows black smoke out of my exhaust pipes. And other times it will start.. but then it stutters and dies or acts like it wants to die. I have changed spark plugs.. fuel injectors.. starter.. gas filter. I am clueless and would appreciate it if you had any good feedback for me. Thanks

September 07 16:05 by nroblez This question hasn't been paid for. You can make an offer

Make an offer
2005 Ford Taurus
There is a steady whine from the front end. It sounds like bad wheel bearings. It does not change on accel. or decel. Is there something other than wheel bearings that might cause this sound?

September 07 10:00 by rjfjelstad This question hasn't been paid for. You can make an offer

Make an offer
1997 Honda Accord
The horn went off while the car was parked and locked and won't stop. Took out the relay but has rendered the car hornless. Please advise what I should do to solve the problem.

September 07 05:31 by Elias This question hasn't been paid for. You can make an offer

Make an offer
97 Chevrolet Cavalier Z24
Can I put an 03 cavalier steering wheel in my 97 cavalier?

September 06 14:24 by aj921128 This question hasn't been paid for. You can make an offer

Make an offer
2001 Nissan Pulsar
Pulsar Q Hatch 2001. Hesitant/chugging while at high speed or under load. A few weeks ago I had rocker cover gasket replaced and the next time I drove on freeway it struggled after about 30 mins as I was going up hill, as I accelerated a LARGE amount of smoke was coming out. Took it to mechanic and found when other place changed gasket they didnt disconnect hose and oil went into air intake. Had it all cleaned out and full service and was running fine but again on highway after about 30 mins was struggling again, no smoke this time. It felt like going on a bumpy road, then as I accelerated to try and pick up speed it felt like I was breaking. Slowed down and gradually sped up going down hill and would work fine until uphill or accelerating quickly. Took it back and they said was fuel pump and had it replaced. It happened again.... anyone have any ideas what is actually wrong?

September 06 04:20 by leeanneeee This question hasn't been paid for. You can make an offer

Make an offer
1987 Honda Accord
1987 Honda Accord - I Have An 1987 Honda Accord And It Runs Beautifully...but Every Time It Rains It Loses The Power And Slowly Dies And Then I Have To Pull Over And Turn It Off And Wait 5 Minutes Then It Runs Again. I Cant Figure Out The Problem.

September 04 20:38 by seth47 This question hasn't been paid for. You can make an offer

Make an offer
1994 Engine Buick 3800
I have a 1994 buick lesabre limited it starts and it makes a loud noise in engine and then when you drive in the stalls out

September 04 15:52 by Bruce_81 This question hasn't been paid for. You can make an offer

Make an offer
1990 Honda 1990
tac and speedo turn off, battery lite

September 04 04:58 by riegej23 This question hasn't been paid for. You can make an offer

Make an offer
1992 Ford 92 Ford Explorer
I have a 92 Explorer and i but a new tranny radiator coolent on it and changed the fluids twice and filter. Buut for some reason it will kick down tell in all gears tell i hit 65-70 and it won't kick down to 2500 rpms it stays at 3000 and won't shift down more speed higher rpms. like take on highways but don't want run it like that. I would apreciate the help out of ideas. Thanks David

September 03 20:25 by dsmerker This question hasn't been paid for. You can make an offer

Make an offer
2007 Nissan Nissan Maxima
Most of the time when i press the acceleration of my car there is a vibration in the engine. i can hear that noise in the different speed. the sounds is loud, it depends if you will press the gas right away at 3000 rpm the sounds is loud but i've noticed when the speed is steady in any speed there is no vibration but once you will press the accelerator there is a vibration. the vibration is on and off.

September 03 15:53 by aldin This question hasn't been paid for. You can make an offer

Make an offer
1995 Nissan Maxima
Wife was driving home when the serpentine belt let go, I just replaced the idle pulley about 2 weeks ago, how do I find out which pulley is frozen?

September 03 15:42 by Apache71 This question hasn't been paid for. You can make an offer

Make an offer
97 Ford Escort LX
I own a 97 ford escort LX that keeps overheating...looking for any answer other than head gasket haha. Have flushed radiator checked hoses, replaced radiator cap, new thermostat (which came out in about three pieces). It idles at a normal temp but when driving it climbs and almost pegs out within 5 miles. Most of the time it empties the radiator into the reservoir tank but not always. Fan works fine, AC only works for about 10 min then turns to hot air. Nothing coming from exhaust and no evidence of coolant in oil. I know the engine is getting coolant from the radiator because I have taken hoses and the water outlet off several times and always looks like good coolant. It can idle for 20 min on a hot day with the ac on and never get hot...also each time it has overheated I am always sure to belch the radiator to make sure there is no air trapped...HELP!!

September 03 14:23 by Zack0221 This question hasn't been paid for. You can make an offer

Make an offer
1998 Ford Contour
Runs good but when outside temp gets 25 or below wont idle but still runs good

September 03 14:15 by Brady This question hasn't been paid for. You can make an offer

Make an offer
1989 Ford Bronco 2
Okay I have a 1989 Ford Bronco 2 when I first crank it up it runs fine but I can go down the road for a couple miles and it just shut off sometime it will crank right back up some it will take a few minutes can you help me with that

September 03 04:03 by andreredd This question hasn't been paid for. You can make an offer

Make an offer
1984 Ford Bronco Ll
all my radiator fluid leaked out underneath where oil filter located. what is that from? someone said it was the line that cools transmission..I had my engine rebuilt just prior to this, and mechanic and I are on the outs, I need help

September 02 22:20 by michelin This question hasn't been paid for. You can make an offer

Make an offer
2004 Engine Toyota 2.4L
my 2004 2.4L camry has a very high idle,2200 RPM,but 98% of the time, it is only when first starting car for the day. so cold start. What could be the cause of this?

September 02 15:50 by joanie3 This question hasn't been paid for. You can make an offer

Make an offer
86 Engine Toyota 3sge
Iv got an 86 toyota celica gts, When i drive at highway speeds for more them about 45 minutes, the car starts to hesitate, its completely shut off on me 2 twice. if i let it sit and cool off for a little it will run fine for about 45 minutes and start to do it again, its a manaul trans. ill put my foot into the gas and it wont accelerate but if i back my foot off and and ease into the throttle it will accelerate better. Any ideas?

September 01 15:51 by joshkey123 This question hasn't been paid for. You can make an offer

Make an offer
1992 Honda Accord
Was driving down the street the car shut off and now it want crank.

September 01 06:34 by Jstanmem This question hasn't been paid for. You can make an offer

Make an offer
1997 Ford Thunderbird
The engine misfires really bad and it blows the run fuse as soon as you install it

August 31 15:33 by rigol1976 This question hasn't been paid for. You can make an offer

Make an offer
1993 Ford Escort
car wont shift unless car restarted. had clutch adjusted

August 31 13:36 by bobmullr This question hasn't been paid for. You can make an offer

Make an offer
2003 Chevrolet Cavalier
I am having a lot of trouble starting my care and whenit does start black smoke comes from exhaust pipe. I have changed the fuel filter, air filter and upper oxygen sensor. each thing made it run better for 1-2 days and then back to same problem.

August 30 15:43 by nadinemhunt This question hasn't been paid for. You can make an offer

Make an offer
1998 Chevrolet Cavalier
need to locate the air charger location

August 30 09:01 by messer This question hasn't been paid for. You can make an offer

Make an offer
1993 Ford Mustang GT
Mustang GT 1993 with 103,000 miles it started smoking and it has never been hotrodded it set up for years when I got it you can not stand behind it cause it burns your eyes like it's getting to much gas and it won't turn up it has a miss in it and if you push it you can here it popping but it started slow just a miss here and there like in 5th gear just a little miss it's got bad. It don't leak oil but I have to put some in it every hundred miles or so and it won't smoke unless I get in it. Could it be my plugs or something more I put it on a tester and it said coolent sensor and mass air flow and not enough votage to something and it setting up for a while could it have something to do with it? Car is in meant shape. Help any one please I got it for my son to drive to play collage football and it's keep getting worse. Thanks so much for your time.

August 30 00:05 by Frank_Calvert This question hasn't been paid for. You can make an offer

Make an offer
2002 Ford 2002 Ford Explorer
2002 Ford 2002 Ford Explorer - My 2002 Ford Explorer Has A Tapping On The Drivers Side In The Engine. Sounds Like Possibly A Rocker Arm Or Push Rod. Is There Any Thing Else It Could Be? Also Did This Model Come With A Timing Chain Or Belt? Thanks!

August 29 19:32 by CathyK This question hasn't been paid for. You can make an offer

Make an offer
1972 Engine Ford 72 351 Cleveland In A 2000 F150
i have 2000 f150 that i put a 72 351 cleveland with 400 heads all stock except heads. I set the timing with light. motor just rebuilt completetly has approx 900 miles on it and no matter how much i adjust dist carb points it seems to missing but if i just lay my foot on gas it does great but as soon as i try to give it gas it starts spitting spudduring poppping back through carb and exhaust. can anyone help. Thanks Chris

August 28 10:05 by chrisgr31 This question hasn't been paid for. You can make an offer

Make an offer
1995 Ford F150
Hi I have 1995 f150 with 5.0 with dual tanks. I was driving and it shut off. Iit turned over but wouldn't start I had it towed home and checked the battery, fuel kill button and pushed it, and both fuel pumps are working and has full tanks. Still turns over but will not fire what else could it be?

August 27 11:43 by gmannn This question hasn't been paid for. You can make an offer

Make an offer
1990 Nissan 1990 Nissan Maxima Vg30e
sir when i'm on motion with my 1990 nissan maxima it runs well but the moment it's temperature rises to the middle the car will starts jerking gradually and it will find it difficult to pick up acceleration unless I throttle more, before it will then pick. I've changed spark plugs, fuel filter, fuel pump. The problem remains. Regards Victor

August 27 10:13 by Victor_Bush This question hasn't been paid for. You can make an offer

Make an offer
1997 Ford Explorer
theres a alarm type sound when i try to start my 97 explorer 4.0 it comes from passanger side

August 26 09:40 by omar_ This question hasn't been paid for. You can make an offer

Make an offer
2001 Chevrolet Cavalier
driving on hwy and twice my car felt like it lost power, pushed on gas nothing happened then it fixed it self, when i got to a light and it died no noise at all no clicking nothing. radio, dash panel and the doorbell doesn't work, but the headlights, horn,flashers work. anyone know why? i did have the battery tested.

August 25 21:14 by lorelie This question hasn't been paid for. You can make an offer

Make an offer
1995 Ford Explorer
What is the length of the oil dipstick for 1995 ford explorer v-6 4.0 liter?

August 25 10:28 by amberstar78 This question hasn't been paid for. You can make an offer

Make an offer
1996 Nissan Maxima Gle
had new motor installed and now my rpm does not work the codes are for knock sensor and cam sensor I replaced the cam sensor

August 24 10:57 by edtyler74 This question hasn't been paid for. You can make an offer

Make an offer
1999 Ford Taurus
I have had 2 rebuilt transmissions installed. I have had the speed sensor changed 3 times. If i start the car cold it shifts fine until the car is fully warmed up. Then when i stop or shut off the car the speedometer will quit and the transmission will either not shift to 2nd or does a hard shift. The abs light will come on occassionaly as well as the speedometer returning to normal operation then shifts fine. If I stay at higher speeds when the speedometer goes off it shifts ok at the higher end but from a stop its hit or miss . Sometimes the speedometer will go to zero on the highway and then come back up to normal on its own I cant see any consistent cause other than possibly heat but when i put it in for testing all i get is egr codes and that has been replaced as well. Check engine always comes back egr valve but thats not it.

August 24 09:53 by fbourbon1970 This question hasn't been paid for. You can make an offer

Make an offer
1998 Pontiac Sunfire
My 1998 Sunfire runs ok when you start it but when you drive it it will run rough for periods and then will want to stall. This happens most often when you put the brakes on. Some times it will not start right away. I have to pump the accelerator a lot to get it to start It also puts out black smoke after it starts. Also sometimes after starting it accelerates on its own.

August 23 18:08 by cculgan This question hasn't been paid for. You can make an offer

Make an offer
2002 Ford Explorer
starter turning over before cranking

August 23 16:47 by spielershawn This question hasn't been paid for. You can make an offer

Make an offer
1996 Ford 1996
My truck stops running when im dirving.an it indel up by its own.what should i do to fix it?

August 23 07:53 by Megan This question hasn't been paid for. You can make an offer

Make an offer
1996 Honda Civic
1996 Honda Civic - won't shift at all without key in the shift lock

August 22 20:28 by gotmyhonda This question hasn't been paid for. You can make an offer

Make an offer
1992 Honda Prelude
1992 Honda Prelude - My 1992 Prelude Kinda Stutters And Sometimes Dies When Coming To A Stop. The Oil Lamp Light Also Comes On For A Brief Moment When Coming To A Stop. I Know The Car Is Leaking Oil As Well. Can You Help Me?

August 22 11:30 by roman93 This question hasn't been paid for. You can make an offer

Make an offer
2005 Ford Taurus
My Ford taurus 2005 is having flashing airbag code 16. How to fix that?

August 20 19:39 by anurodh04 This question hasn't been paid for. You can make an offer

Make an offer
2001 Ford Explorer Sport
I have a 2001 ford explorer sport v6 4.0L soch the gas peddel sits further back then normal what can cause that also I have noticed the throttle cable has slack how can i fix this

August 20 18:40 by TK4916 This question hasn't been paid for. You can make an offer

Make an offer
2000 Mercedes-Benz S430
Rear window, passenger side, won't roll up or down. The other 3 windows are fine. What could be the problem?

August 20 14:01 by maya This question hasn't been paid for. You can make an offer

Make an offer
Ford 1996
My 96 mustang gt's airbag light just came on the other day and has stayed on every time the car is on, since this has happened my blinkers have also stopped working. The hazards work though. I bought this car a few months ago and this is the first time I've had a problem like this. Any idea how to fix this? Thank you

August 20 09:58 by ny4l83 This question hasn't been paid for. You can make an offer

Make an offer
1999 Ford Taurus
What would cause a 1999 Ford Taurus to lose power when you touch the accelerator you do not gain any speed , just continue to lose speed. The air bag light also comes on and stays on. All of my gauges stop working , and the car is really hot . When you open the hood steam is coming from the engine.

August 19 18:35 by mandey86 This question hasn't been paid for. You can make an offer

Make an offer
1996 Chevrolet Cavalier
my 1996 cavalier 2.2 l seems to have a blown head gasket but there is no coolant loss or overheating and no oil in coolant or coolant in oil ?

August 19 16:41 by edwin55 This question hasn't been paid for. You can make an offer

Make an offer
1994 Ford Mustang
5.0-302 gt h.o. trans started leaking as I would attempt passing gear on a.o.de tranny....it wouldn't make it into high acceleration at all but instead spew tranny fluid...so I babied it...today I gave it full throttle and eureka the car took off fast...then 15 seconds later poured out more tranny fluid than I could imagine...appears to be from front area ...seal?? help!!

August 19 14:44 by mustanglvr94 This question hasn't been paid for. You can make an offer

Make an offer
1999 Ford Taurus Se
In my 1999 Ford Taurus se 3.0 engine,the battery light comes on for about 1-3mins then goes off then might come back on or not. This doesnt happen every day.I had it checked at parts store. They said starter, alt, and battery were good (new battery). No problems starting or running.

August 19 10:43 by taperk61 This question hasn't been paid for. You can make an offer

Make an offer
1992 Engine Ford Mustang
1992 ford mustang has a bad vibration at idle

August 17 21:31 by Romelgo This question hasn't been paid for. You can make an offer

Make an offer
1994 Ford 1994
at times the engine acts like it shuts off doesn't stall or quit running. have changed coil, plugs,wires,rotor, rotor cap, fuel filter, clean fuel injectors, it seems worse at around 45mph. ehgine is a 1994 351 Windsor in a ford e350 motor home

August 17 17:55 by redwings19 This question hasn't been paid for. You can make an offer

Make an offer
1989 Engine Ford 351
1989 Bronco 351 ci engine...Rough idle on start-up ..then bucking (no pun intended) and power loss on acceleration. Checked all major sensors, everything seems good. Any ideas of cause?

August 17 13:32 by robsbronco This question hasn't been paid for. You can make an offer

Make an offer
2003 Ford Explorer
2003 Ford Explorer - Bought V8 Explorer Awd In Brisbane Qld. Had Rough Look At Controls Etc Didnt Have Time For Manual. Started 500km Drive Home,Had Servere Knock When Turning Into Car Park Spots At Service Stations On Way Home. Did A Uturn At Home In The Culdesac It Felt Like It Had A Lock Diff. I Later Find After Reading Manual It Was In 4wd Auto Whole Trip. How Much Damage Can I Have Possibly Done. What Work Or Inspections Are Required Cheers

August 17 12:46 by smokie This question hasn't been paid for. You can make an offer

Make an offer
2003 Ford Explorer
Bought v8 explorer awd in brisbane qld. Had rough look at controls etc didnt have time for manual. Started 500km drive home,Had servere knock when turning into car park spots at service stations on way home. Did a uturn at home in the culdesac it felt like it had a lock diff. I later find after reading manual it was in 4wd auto whole trip. How much damage can I have possibly done. What work or inspections are required cheers

August 17 12:45 by smokie This question hasn't been paid for. You can make an offer

Make an offer
1998 Engine Ford F150 V8
'The temperature light comes on but the temperature guage does not move up at all, I checked the fluid level and it was low. I let the engine cool and filled with water and antifreeze but the light stays on when I start the truck back up....what to check next?'

August 17 08:06 by gregd This question hasn't been paid for. You can make an offer

Make an offer
1989 Ford Broco
I have a 1989 ford bronco fuel injection v8. It started where we would be driving and it would die on us. It would start back up. Now it will start but will just die before we out in gear. Have changed the air filter, fuel fikter, inertia switch and I'd len air sensor but st when we start it cranks right up and then dies.

August 17 06:25 by bronco This question hasn't been paid for. You can make an offer

Make an offer
1984 Dodge 1984 Rampage
1984 dodge rampage wont run right when gets warm, will run for a couple miles then acts up. replaced engine coil& timing belt. used to shut off after 3-4 miles is a little better now but still acts up when starts to get hot?

August 16 14:26 by tstarks This question hasn't been paid for. You can make an offer

Make an offer
1988 Honda Prelude
I have a 1988 Honda prelude 2.0 fi manual transmission that is sluggish in first gear and reverse. If I am at a stop light and give it gas it will hesitate to go. I takes off very slow and then builds up and then everything seems fine when I go to second. It also does it in reverse but not sure if the problem is related. I don't think it's tranny problems. It idles fine. It revs up fine, it's just only when it under a load when it does not want to pull. If a tach it up in first it will go.

August 16 07:59 by Machaux This question hasn't been paid for. You can make an offer

Make an offer
2003 Honda Accord
2003 Honda Accord ---a/c vibration

August 15 22:00 by hondagirl2002 This question hasn't been paid for. You can make an offer

Make an offer
1999 Chevrolet Cavalier
Why does turning my headlights on cause my radiator fan to slow down, which causes the car to overheat? The radiator, reservoir, cap, thermostat, etc... are all good. The engine temp is fine during the daytime, regardless of open road or in town driving. When I turn on the lights, even during daytime, the fan slows down and the engine overheats. If it turn off the lights at night, the temp comes back down. Is there a common connection, fuze, or wire I could check? The battery seems fine and the terminals are clean. I suspect a corroded wire or fuze or connector, but haven't found it yet. Thanks for any help you can provide ;-)

August 14 15:57 by cavalier-chris This question hasn't been paid for. You can make an offer

Make an offer
1989 Ford Thunderbird
1989 Ford Thunderbird SC with the 5 speed. 112k miles. I bought this car 4 months ago and took it to a local shop to have them do the belts and hoses. I got the car back and the system monitor on the dash had stopped working. I have driven it another 200 miles since the service, but yesterday the brakes would not work. Nor would the HVAC fan and the turn signals. Fuses and relays all look good. What ties these systems together and/or what do I go after to fix this thing? Thanks!

August 14 09:28 by rjwinans This question hasn't been paid for. You can make an offer

Make an offer
2000 Ford Taurus
2000 Ford Taurus - I Have A 2000 Ford Taurus 3.0L V6 And The Guy That Sold It To Me Changed The Output Speed Sensor And The Front 3 Spark Plugs. The Next Morning I Noticed That The Car Didnt Want To Start Unless I Pressed The Gas. I Changed The Remaining 3 Plugs And All The Wires. Then Noticed It Was Missfiring So I Checked It. It Said Plug 2 And 3 Was The Problem So I Fixed That Plus Had To Replace The EGR Valve Pressure Sensor Too. Now The Car Dont Seem To Missfire But Is Even Worse When Trying To Start It Up Now U Have To Pump The Gas. Also At Stop Lights It Seems To Sputter Alittle But When U Go To Take Off It Acts Like Its Goona Go But Stalls Out. It Eats A Lot Of Gas Plus Has A Horrible Odor When Trying To Start It. The Check Engine Light Is On And Flashes Every Once In A While.

August 12 18:36 by bigt69 This question hasn't been paid for. You can make an offer

Make an offer









Links     |     Privacy     |     About Us     |     Contact Automobile Answers     |     Bookmark Us     |     Get Answers Fast

Automobile Answers     -     www.automobileanswers.com